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ВСТУП 

 

Метою вивчення навчальної дисципліни «Імітаційне 

моделювання у системах водопостачання і водовідведення» є 

формування у студентів системних теоретичних та практичних 

знань основ імітаційного моделювання у водопостачанні та 

водовідведенні. 

До виконання лабораторних робіт студенти допускаються 

після опрацювання даних методичних вказівок. 

Результати виконання кожної лабораторної роботи 

оформлюються в електронному вигляді (на комп’ютері). В кінці 

кожної лабораторної роботи студент представляє викладачу 

результати її виконання, а викладач оцінює ступінь виконання 

та заносить отримані бали у журнал. В разі невиконання певної 

лабораторної роботи з об’єктивних причин, студенти мають 

право, за дозволом директора інституту, її відпрацювати. Час та 

порядок відпрацювання визначається викладачем. 

 

 

ЛАБОРАТОРНА РОБОТА №1. Робочий простір програми 

EPANET 

 

Мета роботи: вивчити інтерфейс програми EPANET. 

 

Загальні відомості. 

EPANET – комп'ютерна програма, розроблена Агентство 

США по захисту довкілля, що здійснює моделювання 

гідравлічного режиму й якості води за тривалий період в 

напірній трубопровідній мережі. 

У програму входить сучасний пристрій для гідравлічного 

аналізу, що включає в себе наступні можливості: 

• здійснює аналіз мережі будь-якого розміру без обмежень; 

• розраховує втрати напору за довжиною трубопроводу з 

використанням формул Хазен-Вільямса, Дарсі-Вайсбраха або 

Чезі-Меннінга; 

• розраховує малі втрати напору в арматурі та фасонних 

частинах; 
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• моделює роботу насосів з постійною або регульованою 

швидкістю; 

• розраховує споживання насосами електроенергії; 

• моделює різні типи засувок, включаючи запірні, зворотні 

клапани, клапани вирівнювання тиску та дроселі; 

• дозволяє розрахувати будь-які форми резервуарів 

(наприклад, діаметр може змінюватися при зміні висоти); 

• враховує різні категорії споживання на вузлах з різними 

часовими моделями; 

• моделює потоки, що залежать від тиску та випускаються 

емітерами (розбризкувачами); 

• виконує системний аналіз як на базі зміни рівнів води в 

резервуарі або часового контролю, так і на базі спеціально 

заданих умов регулювання. 

Програма EPANET надає наступні можливості моделювання 

якості води: 

• моделює рух за часом інертних індикаторних добавок в 

мережі; 

• моделює рух та зміну концентрації реагентів (наприклад, 

побічні продукти знезараження, залишкового хлору) за часом; 

• моделює час перебування води в мережі; 

• відстежує коефіцієнт потоку від певного вузла до інших 

вузлів за часом; 

• моделює реакції, як в масовому потоці, так і реакції з 

матеріалом стінок труб; 

• використовує кінетику n-го порядку для моделювання 

реакцій в масовому потоці; 

• використовує кінетику нульового або першого порядку для 

моделювання реакцій на стінці труби; 

• враховує обмеження перенесення речовини при 

моделюванні реакцій на стінці труби; 

• дозволяє продовжити реакції зміни концентрації до 

допустимих концентрацій; 

• використовує коефіцієнти реакцій, які можуть бути змінені 

в залежності від матеріалу та стану труб; 

• дозволяє корегувати коефіцієнти впливу на стінки труби з 

урахуванням шорсткості труб; 
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• враховує тимчасову концентрацію або масові надходження 

в будь-якому місці мережі; 

• моделює резервуари: змішаний тип, проточні або 

двокамерні. 

При використанні цих властивостей EPANET може вивчати: 

• змішування води з різних джерел; 

• час перебування води в мережі; 

• зміну концентрації залишкового хлору; 

• зміну концентрації побічних продуктів дезінфекції; 

• відстеження поширення забруднення. 

 

Хід роботи 

Робочий простір EPANET складається з наступних елементів: 

рядок меню, дві панелі інструментів (стандартна панель 

інструментів, панель інструментів Карти), рядок стану, вікно 

карти мережі, вікно перегляду та вікно властивостей. 

Рядок меню Панелі інструментів

Карта мережіРядок стану
Редактор 

властивостей

Вікно 

перегляду
 

Рис. 1.1. Вікно програми EPANET 

 

Рядок меню розташована вгорі робочого простору програми 

та складається з набору меню, які використовуються для 
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управління програмою: Файл (File); Правка (Edit); Вид (View); 

Проект (Project); Звіти (Report); Вікна (Window); Довідка (Help). 

Меню Файл (File) містить команди (табл. 1.1). 

           
а)                                                 б) 

Рис. 1.2. Меню Файл (а) та меню Правка (б) 

 

Таблиця 1.1 

Меню Файл (File) 

Команда Опис 

Створити (New) Створює новий проект EPANET 

Відкрити (Open…) Відкриває існуючий проект 

Зберегти (Save) Зберігає поточний проект 

Зберегти як (Save As…) 
Зберігає поточний проект під іншим 

ім'ям 

Імпортувати (Import) 
Імпортує дані мережі або карту з 

файлу 

Експортувати (Export) 
Експортує дані мережі або карту з 

файлу 

Параметри сторінки 

(Page Setup…) 

Встановлює поля, верхній і нижній 

колонтитули для друку 
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Попередній перегляд 

(Print Preview) 
Попередній перегляд друку 

Друк (Print) Друкує поточний документ 

Налаштування 

(Preferences…) 
Встановлює налаштування програми 

Вихід (Exit) Вихід з програми 

 

Меню Правка (Edit) містить команди для редагування та 

копіювання. 

Таблиця 1.2 

Меню Прака (Edit) 

Команда Опис 

Копіювати (Copy 

To) 

Копіює поточне активне зображення 

(карта, звіт, графік або таблиця) в буфер 

обміну або в файл 

Виділити об'єкт 

(Select Object) 
Дозволяє вибрати об'єкт на карті 

Виділити вершину 

(Select Vertex) 
Дозволяє вибрати вершини ланок на карті 

Виділити область 

(Select Region) 

Дозволяє вибрати виділену область на 

карті 

Виділити все 

(Select All) 
Дозволяє вибрати всю область карти 

Редагувати групу 

(Group Edit…) 

Редагування властивості групи об'єктів, 

виділених в якійсь області карти 

 

Меню Вид (View) управляє зображенням карти. 

Таблиця 1.3 

Меню Вид (View) 

Команда Опис 

Розміри 

(Dimensions…) 
Розміри карти 

Підкладка 

(Backdrop…) 

Дозволяє побачити зображення фону на 

карті та завантажувати базові карти 

Зрушити (Pan) 

 
Дозволяє переміщати карту 
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Збільшити масштаб 

(Zoom In) 
Збільшує масштаб 

Зменшити масштаб 

(Zoom Out) 
Зменшує масштаб 

Весь проект (Full 

Extent) 
Показує карту в повному розмірі 

Знайти (Find…) 
Визначає розташування певного розміру 

на карті 

Запит (Query…) 
Пошук об'єктів, що задовольняють 

певним критеріям, на карті 

Огляд карти 

(Overview Map) 
Включає/відключає огляд карти 

Легенди (Legends) Контролює відображення легенд карти 

Панелі інструментів 

(Toolbars) 
Включає/відключає панелі інструментів 

Параметри 

(Options…) 

Встановлює опції зовнішнього вигляду 

карти 

 

          
а)                                              б) 

Рис. 1.3. Меню Вид (а) та меню Проект (б) 

 

Меню Проект (Project) включає в себе команди, які 

стосуються поточного проекту. 
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Таблиця 1.4 

Меню Проект (Project) 

Команда Опис 

Зведена інформація 

(Summary…) 

Надає зведений опис 

характеристик проекту 

Налаштування за 

замовчуванням (Defaults…) 

Редагує значення проекту за 

замовчуванням 

Дані калібрування (Calibration 

Data) 

Реєструє файли, що містять 

дані калібрування 

Параметри аналізу (Analysis 

options…) 
Редагує параметри аналізу 

Аналізувати (Run Analysis) Запускає моделювання 

 

Меню Звіт (Report) містить команди, що використовуються 

для формування звітів за результатами аналізу. 

Таблиця 1.5 

Меню Звіт (Report) 

Команда Опис 

Стан (Status) Звіт про зміни стану ланок за часом 

Електроенергія 

(Energy) 

Звіт по електроенергії, яка споживається 

кожним насосом 

Калібрування 

(Calibration) 

Звіт про різницю між модельованими та 

вимірюваними величинами 

Реакція (Reaction) 
Звіт про середні коефіцієнти реакцій по всій 

мережі 

Повний (Full…) 

Створює повний звіт за розрахованими 

результатами для всіх вузлів і ланок в усі 

часові періоди; зберігається в текстовий 

файл 

Діаграма 

(Graph…) 

Створює різного виду схеми обраних 

параметрів 

Таблиця 

(Table…) 

Створює табличний звіт кількісних 

характеристик обраного вузла або ланки 

Параметри 

(Options…) 

Контролює стиль відображення звіту, 

графіка або таблиці 
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а)                                                         б) 

Рис. 1.4. Меню Звіт (а) та меню Вікно (б) 

 

Меню Вікно (Window) містить наступні команди (табл. 1.6). 

 

Таблиця 1.6 

Меню Вікно (Window) 

Команда Опис 

Впорядкувати 

(Arrange) 

Розміщує всі вікна всередині головного 

вікна 

Закрити все (Close 

All) 

Закриває всі відкриті вікна (крім Карти 

та Перегляду) 

Список вікон 
Список всіх вікон; поточне вікно 

виділене «галочкою» 

 

Меню Допомога (Help) містить команди для отримання 

допомоги в роботі з програмою EPANET (рис. 1.5). Меню 

Допомога також можна викликати, якщо натиснути клавішу F1. 

Панелі інструментів забезпечують швидкий виклик 

операцій. Є дві панелі інструментів: 

• Стандартна панель інструментів (Standard); 

• Панель інструментів Карти (Map). 

Панелі інструментів можуть розташовуватися нижче панелі 

Головного меню або в будь-якому місці робочого простору 

EPANET. При переміщенні панелі інструментів, можна 

змінювати їх розміри. Панелі інструментів можна зробити 
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видимими або невидимими, якщо вибрати меню Вид → Панелі 

(View → Toolbars). 

 
Рис. 1.5. Одиниці вимірювання для всіх параметрів програми EPANET 

(локалізації: витрата – л/с, втрати напору – формула Дарсі-Вейсбаха) 

 

Стандартна панель інструментів (Standard) містить кнопки 

швидкого виклику команд: 

 
Створює новий проект: Файл → Створити (File → 

New) 

 
Відкриває існуючий проект: Файл → Відкрити (File 

→ Open…) 

 
Зберігає поточний проект: Файл → Зберегти (File → 

Save) 

 
Друкує поточне активне вікно: Файл → Друк (File → 

Print) 

 
Копіює вибрану область в буфер обміну або в файл: 

Редагувати → Копіювати (Edit → Copy To…) 
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Видаляє обраний об'єкт (Del) 

 
Знаходить певний об'єкт на карті: Вид → Знайти 

(View → Find…) 

 
Запускає моделювання: Проект → Аналізувати 

(Project → Run Analysis) 

 
Запускає візуальний запит на карті: Вид → Запит 

(View → Query…) 

 
Створює новий графік перегляду результатів: Звіти → 

Діаграма (Report → Graph…) 

 
Створює нову таблицю перегляду результатів: Звіти 

→ Таблиця (Report → Table…) 

 

Змінює параметри поточного активного зображення: 

Вид → Параметри (View → Options…) або Звіт → 

Параметри (Report → Options…) 

 

Панель інструментів карти (Map) містить кнопки для 

роботи з картою мережі: 

 
Вибирає об'єкт на карті: Редагування → Виділити об'єкт 

(Edit → Select Odgect) 

 
Вибирає вершинні точки ланок: Редагування → 

Виділити вершину (Edit → ) 

 
Вибирає область на карті: Редагування → Виділити 

область (Edit → Select Vertex) 

 
Переміщує карту: Вид → Перемістити (View → Pan) 

 
Збільшує карту: Вид → Збільшити масштаб (View → 

Zoom In) 

 
Зменшує карту: Вид → Зменшити масштаб (View → 

Zoom Out) 

 
Показує карту в повному розмірі: Вид → Весь проект 

(View → Full Extent) 

 
Додає на карту з'єднання (Add Junction) 

 
Додає на карту джерело (Add Reservoir) 

 
Додає на карту резервуар (Add Tank) 

 
Додає на карту трубу (Add Pipe) 
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Додає на карту насос (Add Pump) 

 
Додає на карту засувку (Add Valve) 

 
Додає на карту текстовий блок (Add Label) 

 

Рядок стану знаходиться в нижній частині робочого 

простору програми та розділений на чотири частини, в яких 

відображаються такі елементи: 

1 2 3 4 5
 

Рис. 1.6. Рядок стану 

 

• Авторозрахунок довжини (поз. 1) – показує включений або 

виключений автоматичне визначення довжини труби. 

• Одиниці виміру потоку (поз. 2) – показує, які одиниці 

вимірювання потоку обрані. 

• Стан аналізу (поз. 3) – іконка у вигляді водопровідного 

крана, яка показує: 

 
води не витікає з крана, якщо немає результатів 

аналізу; 

 

вода витікає з крана, якщо результати аналізу 

правильні; 

 

кран зламаний, якщо результати аналізу є, але вони 

можливо неправильні; 

• Масштаб (поз. 4) – показує поточне масштабування карти 

(100% – повний масштаб); 

• Координати X і Y (поз. 5) – відображає координати 

поточної позиції курсору. 

Карта Мережі надає плоску схематичну діаграму з об'єктів, 

що становлять водопровідну мережу. Розміщення об'єктів і 

відстань між ними не обов'язково має відповідати їх фізичному 

масштабу. Вибрані властивості цих об'єктів, такі як якість води 

на вузлах або швидкість потоку в ланках, можуть відображатися 

за допомогою різних кольорів. Кольорове маркування 

описується в легенді, яку можна редагувати. Можна додати 

новий об'єкт на карту, а існуючі об'єкти можна редагувати, 
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знищувати або переміщати, якщо клацнути по ним мишею. Для 

довідок на задньому фоні (підкладці) карти мережі може 

розміщуватися карта вулиць або топографічна карта. Карту 

можна зменшувати або збільшувати в розмірах. Вузли та ланки 

можуть бути будь-якого розміру, можна додавати стрілки, що 

вказують напрями потоків, символи об'єктів, назви та чисельні 

величини. Карту можна роздрукувати, скопіювати в буфер 

обміну Windows або експортувати як файл DXF або метафайл 

Windows. 

Вікно перегляду даних. У вікні Перегляд (Browser) є 

вкладка Дані (Data), яка відкриває доступ до різних об'єктів за 

категоріями (з'єднання, труби тощо), що містяться в мережі. 

Кнопки внизу використовуються для того, щоб видаляти, 

додавати і редагувати ці об'єкти. 

Вибір категорії об”єктів

Список об”єктів 

поточної категорії

Кнопки додавання 

(Add), видалення 

(Delete) та 

редагування (Edit)  
Рис. 1.7. Вікно перегляду, вкладка Дані 

 

Вікно перегляду карти. У вікні Перегляд (Browser) є 

вкладка Перегляд карти (Map). Тут вибираються параметри та 

часовий період, які відображаються на карті мережі за 

допомогою кольору, є кнопки управління анімацією. 
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Вибір параметра вузлів для 

відображення на карті

Вибір параметра ланок для 

відображення на карті

Момент часу для 

відображення

Управління анімацією

Швидкість анімації

 
Рис. 1.8. Вікно перегляду, вкладка Карта 

 

Кнопки управління анімацією: 

 Перемотка (повернення у вихідний час) 

 Анімація назад 

 Зупинити анімацію 

 Анімація вперед 

 

Редактор властивостей (Edit Options). Редактор 

властивостей використовується для редагування (зміни) 

властивостей вузлів, ланок, назв та опцій аналізу. Це вікно стає 

активним, якщо обраний один з цих об'єктів (або на карті мережі 

або в панелі даних), за яким треба двічі клацнути мишею або 

клацнути по кнопці Редагувати (Edit). Редактор властивостей – 

це таблиця з двома колонками, одна для назви властивості 

(Property), інша для його значення (Value). Зірочка поруч з 

назвою властивості означає, що потрібно обов'язково ввести це 

значення. В залежності від властивості, поле значення може 

бути наступним: 

- текстове поле, де вводиться значення; 

- меню, що випадає, де вибирається значення зі списку; 
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- овальна кнопка, натиснувши яку вибирається спеціальний 

редактор; 

- «тільки для читання» для відображення розрахованих 

результатів. 

Текстове поле

Меню; поточна 

властивість

Обов”язкові поля

Результати 

розрахунків

 
Рис. 1.9. Вікно властивостей 

 

Крім того у вікні програми можуть бути присутні вікна 

легенд, таблиці даних, графіки, інформаційні вікна та анімація. 

 

 

ЛАБОРАТОРНА РОБОТА №2. Створення моделі 

водопровідної мережі 

 

Мета роботи: отримати базові навички створення моделі 

водопровідної мережі. 

 

Загальні відомості. 

Програма EPANET представляє модель розподільчої системи 

у вигляді набору ланок, приєднаних до вузлів (рис. 2.1). Ланки – 
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це труби, насоси та запірна арматура. Вузли – це з'єднання, 

водонапірні башти та резервуари. З'єднання – це точки мережі, 

де ланки з'єднуються, та де вода надходить або виходить з 

мережі. 

Водойма Водонапірна 

башта

Насос

Засувка

З'єднання
Т

р
у

б
а

 
Рис. 2.1. Фізичні компоненти розподільної системи 

 

Водойми – це вузли, які представляють безмежне зовнішнє 

джерело, з якого вода надходить в мережу. Вони 

використовуються для моделювання таких елементів як озера, 

річки, підземні водоносні шари та врізки в інші системи. 

Водойми можуть служити точками впливу на якість води. 

Водонапірні башти (резервуари) – це вузли, що мають певну 

місткість води, яка може змінюватися з часом. 

Труби – це ланки, по яких вода транспортується від однієї 

точки мережі до іншої. При використанні EPANET 

передбачається, що труби наповнені водою весь час. Труби 

можна залишати відкритими або закритими в заданий час або за 

певних умов, існуючих в мережі. 

Насоси – це ланки мережі, які передають енергію рідині, 

збільшуючи її гідростатичний напір. Основні параметри насоса 

– це його початкова, кінцева точки та крива напору. 

Засувки (клапани) – це ланки мережі, які обмежують тиск або 

витрату в заданій точці мережі. Розраховані вихідні результати 

для засувок – це витрата води та втрати напору. У програму 

EPANET включені наступні типи засувок: редукційний клапан 

(PRV); клапан вирівнювання тиску (PSV); клапан-переривник 

тиску (PBV); клапан регулювання витрати (FCV); дросельний 

клапан (TCV); універсальний клапан (GPV). 
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Програма EPANET використовує три типи інформаційних 

об'єктів – криві, моделі та пристрої управління, які описують 

поведінку й експлуатаційні аспекти розподільної системи. 

 

Хід роботи 

Проаналізуємо просту водопровідну систему, показану на 

рис. 2.2. Вона складається з джерела-резервуара (наприклад, 

джерело чистої води зі станції водопідготовки), з якого вода 

перекачується в двокільцеву водопровідну мережу. Також є 

трубопровід, що з’єднується з водонапірною баштою. Всі 

компоненти, що показані на рис. 2.2, підписані 

ідентифікаційними мітками (ID). Вузли мережі мають 

характеристики, наведені в табл. 2.1. Характеристики труб 

показані в табл. 2.2. Насос (ділянка 8) може здійснювати підйом 

води на 30 м при витраті води 18 л/с, а водонапірна башта 

(вузол 8) має діаметр 8 м, початковий рівень води в баку 1,0 м 

при максимальному рівні – 5,0 м. 

Таблиця 2.1 

Характеристики вузлів водопровідної мережі 

Вузол Відмітка, м Водовідбір, л/с 

1 30 - 

2 20 4 

3 23 4 

4 24 2 

5 22 3 

6 21 3 

7 50 - 
 

1. Запустити програму EPANET: Пуск → Всі програми → 

EPANET2.0 → EPANET2.0. 

2. Створити новий проект: File → New. 

3. Відкрити діалогове вікно Defaults (налаштування 

проекту за замовчуванням): Project → Defaults… 

Кожен проект має набір величин за замовчуванням. Ці 

значення поділяються на три категорії: 

• Ідентифікаційні мітки (ID Labels) використовуються для 

ідентифікації новостворюваних вузлів і ланок. 
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Рис. 2.2. Схема водопровідної мережі 

 

Таблиця 2.2 

Характеристики труб водопровідної мережі 

Труба Довжина, м Діаметр, мм 
Коефіцієнт 

шорсткості 

1 300 100 2 

2 350 100 2 

3 400 100 2 

4 350 80 2 

5 400 80 2 

6 20 100 2 

7 700 50 2 

 

• Властивості вузла / ланки за замовчуванням (Properties), 

наприклад, відмітка вузла, довжина труби, діаметр і шорсткість. 

• Опції гідравлічного аналізу за замовчуванням 

(Hydraulics),наприклад, система одиниць, втрати напору, 

математичні рівняння тощо. 

Ідентифікаційні назви за замовчуванням (ID Labels). Для 

кожного типу об'єкта можна ввести префікс (приставку на 

початку назви) або не вводити нічого, якщо ідентифікаційна 

назва буде просто номером. Потім номера додаються за 
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зростанням з використанням встановленого збільшення (опція 

ID Increment). Наприклад, якщо буква «В» використовується для 

всіх з'єднань, приріст – 5, то всі з'єднання по мірі їх створення 

отримають назви В5, В10 тощо. Після того, як об'єкт створений, 

Редактор властивостей може використовуватися для зміни назв. 

Крок нумерації

О
б

”є
к
ти

Префікси

Запам'ятати 

для наступних 

проектів

Вузли

Джерела

Резервуари

Трубопроводи

Насоси

Засувки

Моделі

Криві

 
Рис. 2.3. Вкладка ID Labels (Ідентифікаційні мітки) вікна Defaults 

 

3.1. Встановити автоматичну послідовну нумерацію нових 

об'єктів, починаючи з 1: ID Labels → ID Increment ввести 1 

(введене за замовчуванням). 

У вкладці Властивості (Properties) встановлюються значення 

властивостей за замовчуванням для новостворюваних вузлів і 

ланок, а саме: 

• Висотні позначки для вузлів (Node Elevation). 

• Діаметр для башт (Tank Diameter). 

• Максимальний рівень води для башт (Tank Height). 

• Довжина для труб (Pipe Length). 

• Автоматичний підрахунок довжини труб (Auto Length). 

• Діаметр для труб (Pipe Diameter). 

• Коефіцієнт шорсткості для труб (Pipe Roughness). 

Якщо включено властивість автоматичного підрахунку 

довжини, то довжини труб будуть обчислюватися під час їх 



21 

додавання або переміщення на карті мережі. Властивості будь-

яких вузла або ланки, що створені з використанням 

властивостей за замовчуванням, можуть бути змінені за 

допомогою діалогового вікна Редактор властивостей. 

В
л
ас

ти
в
о
ст

і

Висотні позначки вузлів

Діаметр РЧВ / ВБ

Максимальний рівень води в РЧВ / ВБ

Довжина труб

Автоматичний підрахунок довжини труб

Діаметр труб

Коефіцієнт шорсткості труб

 
Рис. 2.4. Вкладка Properties (Властивості вузлів / ланок за 

замовчуванням) вікна Defaults 

 

Вкладка (Hydraulics) використовується для призначення 

опцій гідравлічного аналізу. 

3.2. У полі Flow Units вкладки Hydraulics встановити 

одиницю вимірювання витрат води – LPS (л/с). Тобто, будуть 

використовуватися наступні одиниці вимірювання – довжина в 

метрах, діаметр в міліметрах, тиск в метрах тощо. В якості 

формули для розрахунку втрат напору (поле Headloss Formula) 

вибрати D-W (формула Дарсі-Вейсбаха). 

4. Щоб при додаванні об'єктів (вузлів, ділянок тощо) на 

карту, було видно їх назви та символи потрібно: 

4.1. Відкрити вікно Map Options: View → Options. 

4.2. Вибрати рядок Notation і встановити «галочки» для 

Display Node ID’s та Display Link ID’s (рис. 2.6). 

4.3. Перейти на рядок Symbols і перевірити наявність всіх 

«галочок»: Display Tanks, Display Pumps, Display Valves, Display 
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Emmitters, Display Sources. Це забезпечить відображення 

резервуарів, насосів, засувок, емітерів та джерел умовними 

позначками. 

Одиниця 

вимірювання витрат 

води

Формула для 

розрахунку втрат 

напору

 
Рис. 2.5. Вкладка Hydraulics (Гідравліка) вікна Defaults 

 

5. Налаштуємо параметри масштабу карти, відкривши 

вікно Map Dimensions: View → Dimensions… Оскільки мережа 

буде рисуватися безмасштабно, то потрібно вибрати в полі 

Map Units вибрати None. 

Для побудови мережі, використовуються миша та кнопки на 

панелі інструментів (рис. 2.7, див. лаб. роб. №1). Якщо панель 

інструментів не виведена на екран, то потрібно: View → 

Toolbars → Map. 

5.1. Додамо резервуар-джерело, натиснувши кнопку Add 

Reservoir  на панелі інструментів Map. Потім натисніть 

мишею по карті в тому місці, де буде розташовуватися джерело 

(будь-де зліва на карті). 
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Рис. 2.6. Діалогове вікно вибору опцій відображення карти 

 

 
Рис. 2.7. Панель інструментів Map 

 

 
Рис. 2.8. Карта мережі після додавання вузлів 
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5.2. Додамо вузли з'єднань, натиснувши кнопку Add Junction 

, а потім натискати по карті в місцях, де будуть 

розташовані вузли з'єднань з 2 по 6. 

5.3. Додамо водонапірну башту, натиснувши кнопку Add 

Tank , і натиснути по карті в тому місці, де буде 

розташована башта. Карта мережі буде виглядати приблизно 

так, як показано на рис. 2.8. 

5.4. Додамо труби. Почнемо з труби 1, що з'єднує вузол 2 з 

вузлом 3. Спочатку натиснути кнопку Add Pipe  на панелі 

інструментів. Натиснути на вузол 2 і потім на вузол 3. Лінія, що 

позначає трубу, прорисовується на екрані, коли ведете мишею 

від вузла 2 до вузла 3. Повторити цю процедуру для труб 2-6. 

Труба 7 вигнута. Для того, щоб її нарисувати, натиснути 

спочатку на Вузол 5. Потім по мірі того, як просуваєтеся труба 

до Вузла 6, натиснути мишею в тих точках, де необхідно 

змінити напрям труби. Закінчити процес, натиснувши по 

Вузлу 6. 

5.5. Додамо насос, натиснувши кнопку Add Pump , потім 

по вузлу 1 і вузлу 2. 

5.6. Тепер потрібно підписати джерело, насос і водонапірну 

башту. Виберіть кнопку Add Label  на панелі інструментів і 

натисніть поруч з джерелом (Вузол 1). З'явитися рамка, куди 

можна вводити текст. Надрукуйте слово «Джерело» та натисніть 

клавішу Enter. Зробіть те ж саме для насоса та башти. Потім 

натисніть на кнопку Select Object  на панелі інструментів 

Map для того, щоб працювати в режимі виділення об'єктів, а не 

в режимі введення тексту. 

Створення мережі закінчено. Карта мережі повинна 

виглядати так, як на рис. 2.2. Якщо вузли розташовані не там, де 

потрібно, то можна їх пересунути, натиснувши по вузлу лівою 

кнопкою миші та утримуючи її, перемістити на нове місце. 

Зверніть увагу, що труби, під'єднані до вузла, рухаються разом з 

ним. Підписи можна пересунути таким же чином.  
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5.7. Для того, щоб змінити форму Труби 7, потрібно: 

1. Спочатку натиснути по Трубі 7 для того, щоб виділити її, 

потім натиснути кнопку  на панелі інструментів Map, щоб 

включився режим Select Vertex (виділити вершину). 

2. Вибрати вершину кривої, натиснувши по ній мишею, і 

перемістити її на нове місце, утримуючи ліву кнопку миші. 

3. Якщо потрібно, можна додати вершини або видалити їх, 

натиснувши на точці правою кнопкою миші та вибравши 

відповідний рядок з контекстного меню. 

4. Для закінчення натиснути кнопку Select Object , щоб 

повернутися в режим виділення об'єктів. 

6. Збереження проекту. Після того, як закінчено побудову 

мережі, потрібно зберегти роботу в файл: 

1. З меню File виберіть опцію Save As… 

2. Після того, як з'явиться діалогове вікно, виберіть папку та 

введіть ім'я файлу. 

3. Натисніть ОК для збереження проекту. 

 

 

 

ЛАБОРАТОРНА РОБОТА №3. Одномоментний аналіз 

водопровідної мережі. 

 

Мета роботи: отримати базові навички з установки 

властивостей елементів моделі водопровідної мережі та 

навчитися виконувати одномоментний аналіз водопровідної 

мережі. 

 

Загальні відомості. 

Нанесені на карту об'єкти мають набір характеристик за 

замовчуванням. Щоб змінити значення певної характеристики 

об'єкта, потрібно вибрати об'єкт і відкрити діалогове вікно 

редагування властивостей. Є кілька способів це зробити. Якщо 

вікно Редактор Властивостей вже виведено на екран, можна 

просто натиснути мишею на потрібному об'єкті або ж 

→Browser → Data (знаходиться з права вверху). Якщо вікно 
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зміни характеристик не виведене на екран, то потрібно 

натиснути правою кнопкою миші на об'єкт (вузол, ланка тощо) і 

вибрати рядок Properties з контекстного меню. Властивості 

вузла наведені в табл. 3.1, а труби – в табл. 3.2. Внизу вікон 

властивостей наявні поля з жовтим фоном, де відображаються 

поточні (розраховані) властивості. 

 

 
а)                                                  б) 

Рис. 3.1. Вікна властивостей вузла (а) та труби (б) 
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Таблиця 3.1 

Властивості вузла (Junctions) 

Властивість Опис 

Ідентифікатор  

(Junctions ID) 

Назва, що використовується для 

ідентифікації 

X-координата 

(X-Coordinate) Горизонтальне та вертикальне 

положення вузла на карті Y-координата 

(Y-coordinate) 

Опис 

(Description) 

Необов'язковий рядок, що містить 

довідкову інформацію 

Ярлик 

(Tag) 

Необов'язкова текстовий рядок, що вико-

ристовується для призначення категорії 

з'єднання, наприклад, зона тиску 

Висота  

(Elevation) 

Висота вузла. Висота використовується 

тільки для розрахунку тиску в з’єднанні 

Базове споживання  

(Base Demand) 

Середнє споживання води основною 

категорією споживачів. Від’ємна 

величина використовується подавання 

води у вузол 

Модель споживання 

(Demand Pattern) 

Ідентифікатор часової моделі, що 

використовується для характеристики 

зміни часу споживання 

Категорії 

споживання  

(Demand Categories) 

Кількість різних категорій споживачів, 

визначених для даного з'єднання 

Коефіцієнт емітера  

(Emitter Coeff.) 

Коефіцієнт витрати води для емітера, 

розташованого на з'єднанні 

Початкова якість  

(Initial Quality) 

Якість води в з'єднанні на початку 

періоду моделювання 

Якість джерела  

(Source Quality) 

Якість води, що надходить в мережу в 

даному вузлі з зовнішнього джерела 
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Рис. 3.2. Вікна властивостей резервуара (а) та водонапірної башти (б) 

 

Таблиця 3.2 

Властивості труби (Pipe) 

Властивість Опис 

Ідентифікатор 

(Pipe ID) 
Ідентифікаційна назва труби 

Початковий та кінцевий 

вузли 

(Start Node, End Node) 

Ідентифікаційні назви початкового 

та кінцевого вузлів 

Довжина 

(Length) 
Фактична довжина труби, м 
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Діаметр 

(Diameter) 
Розрахунковий діаметр труби, мм 

Шорсткість 

(Roughness) 
Коефіцієнт шорсткості труби 

Коефіцієнт втрати напору  

(Loss Coeff.) 

Коефіцієнт незначних втрат напору, 

пов'язаний з фітингами тощо 

Початковий стан 

(Initial Status) 

Визначає чи була труба спочатку 

відкрита, закрита або в ній є 

зворотний клапан 

Коефіцієнт реакції 

потоку 

(Bulk Coeff.) 

Коефіцієнт реакції потоку для 

труби. Використовується для 

моделювання зміни якості води 

Коефіцієнт реакції зі 

стінами 

(Wall Coeff.) 

Коефіцієнт реакції зі стінами труби. 

Використовується для моделювання 

зміни якості води 

 

Таблиця 3.3 

Властивості резервуара 

Властивість Опис 

Ідентифікатор 

(Reservoir ID) 
Ідентифікаційна назва резервуару 

Загальний напір  

(Total Head) 

Гідростатичний напір (абсолютна висота 

дна резервуара + висота водяного стовпа) 

води в резервуарі, м 

Модель напору 

 (Head Pattern) 

Ідентифікаційна назва часової моделі, що 

використовується для моделювання зміни 

напору в резервуарі за часом 

 

Таблиця 3.4  

Властивості водонапірної башти 

Властивість Опис 

Ідентифікатор 

Tank ID 

Ідентифікаційна назва водонапірної 

башти 

Висота 

(Elevation) 

 

Абсолютна або відносна висота дна 

водонапірної башти 
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Початковий рівень 

(Initial Level) 

Висота води від дна водонапірної башти 

на початку моделювання 

Мінімальний рівень 

(Minimum Level) 

Мінімально можлива висота води від дна 

водонапірної башти 

Максимальний 

рівень 

(Maximum Level) 

Максимальна висота, м, від дна 

водонапірної башти, яка може бути 

досягнута. Рівень не може бути вище 

цього значення 

Діаметр 

(Diameter) 
Діаметр водонапірної башти, м 

Мінімальний об’єм 

(Minimum Volume) 

Об’єм води у водонапірній башті при 

мінімальному рівні. Застосовується в 

основному для опису конфігурації 

днища нециліндричних башт 

Крива місткості 

(Volume Curve) 

Ідентифікаційна назва кривої, що 

використовується для опису залежності 

між об’ємом водонапірної башти та 

рівнем води 

Модель змішування 

(Mixing Model) 
Тип змішування води в резервуарі 

Пропорція 

змішування 

(Mixing Fraction) 

Використовується для водонапірних 

башт, що складаються з двох камер. 

Можна не заповнювати, якщо 

використовується башта іншої моделі 

змішування 

Коефіцієнт реакції 

(Reaction Coeff.) 

Коефіцієнт реакції потоку для хімічних 

реакцій в башті 

Початкова якість  

(Initial Quality) 

Рівень якості води у водонапірній башті 

на початку періоду моделювання 

Якість джерела  

(Source Quality) 

Якість води, що надходить у башту з 

додаткових джерел або зовнішніх мереж 
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Рис. 3.3. Вікно властивостей насоса 

 

Таблиця 3.5 

Властивості насоса 

Властивість Опис 

Ідентифікатор 

(Pump ID) 
Ідентифікаційна назва насоса. 

Крива накачування 

(Pump Curve) 

Ідентифікаційна назва для кривої 

насоса, яка використовується для 

опису залежності між напором і 

витратою води 

Потужність 

(Power) 
Потужність насоса 

Швидкість 

(Speed) 
Відносна установка швидкості 
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Модель 

(Pattern) 

Ідентифікаційна назва для часової 

моделі, що використовується для 

контролю роботи насоса 

Початковий стан 

(Initial Status) 

Стан насоса (відкритий або закритий) 

на початку періоду моделювання 

Крива ефективності 

(Effic. Curve) 

Ідентифікаційна назва для кривої, яка 

характеризує ефективність насоса як 

функцію від витрати води 

Вартість 

електроенергії 

(Energy Price) 

Середня або номінальна вартість 

електроенергії в грошових одиницях за 

кіловат-годину 

Модель вартості 

(Price Pattern) 

Ідентифікаційна назва часової моделі, 

яка використовується для опису змін 

вартості електроенергії за добу 

 

Хід роботи 

1. Відкрити модель водопровідної мережі, яка розглядалася в 

лабораторній роботі №2. Для того, щоб відкрити проект, 

виберіть команду Open з меню File. 

2. Змінимо характеристики Вузла 2. Введемо висоту 

(відмітку поверхні землі) *Elevation та водовідбір (базове 

споживання) Base Demand у відповідних полях. Потрібно 

тільки натиснути на іншому об'єкті (вузлі або ділянці), та його 

характеристики з'являться у вікні Редактора Властивостей. 

3. Таким чином можна пересуватися від об'єкта до об'єкта 

та заповнювати поля для вузлів – *Elevation (висота) та Base 

Demand (водовідбір), для труб – *Lenght (довжина), *Diameter 

(діаметр) і *Roughness (шорсткість). 

4. Для джерела (Reservoir) введемо висоту (30) в поле *Total 

Head (загальний напір). Для водонапірної башти введіть 50 в 

поле *Elevation, 1 – *Initial Level (початковий рівень), 5 – 

*Maximum Level (максимальний рівень) і 5 – *Diameter 

(діаметр бака, м). 

6. Для насоса необхідно створити криву напору (залежність 

тиск-витрата). В поле Pump Curve (крива напору) введіть 1 

(ідентифікатор кривої). Потім потрібно створити криву 1. 
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Відкриваємо пункт Curves (криві): Browser → Data → Curves і 

натискаємо на кнопку Add. У базу даних додасться Крива 1 і 

з'явиться діалогове вікно Curve Editor – рис. 3.4. Введіть 

проектні характеристики – витрата (18 л/с) та тиск (30 м). 

Програма EPANET автоматично створить криву. Рівняння для 

побудови кривої буде показано у вікні, також як і форма кривої. 

 
Рис. 3.4. Діалогове вікно Curve Editor 

 

7. Запуск одномоментного аналізу. Тепер є достатньо 

інформації, щоб запустити гідравлічний аналіз мережі. Для того, 

щоб запустити аналіз виберіть Project → Run Analysis або 

натисніть кнопку Run на стандартній панелі інструментів. Якщо 

аналіз не буде запускатися, то на екрані з'явиться вікно, де буде 

вказана причина. 

8. Подивитися розраховані результати можна різними 

способами.  

8.1. У вікні Browser → Map (рис. 3.5) у полі Nodes (вузли) 

або у полі Links (ділянки) можна вибрати по одному з 
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параметрів, що відображатимуться у вікні карти під 

відповідними елементами (рис. 3.6). 

Дані

Карта

Вибір параметра вузла

Вибір параметра ділянки

 
Рис. 3.5. Вікно перегляду 

 
Рис. 3.6. Результати розрахунків (витрати на ділянках та п’єзометричні 

відмітки в вузлах) 

 

Крім того, з’явиться легенда з кольоровими діапазонами зміни 

параметрів (рис. 3.6). Для того, щоб подивитися значення 

кольорового маркування виберіть Views → Legends → Node або 

натисніть правою кнопкою миші на порожню частину карти та 

виберіть рядок Node Legend з контекстного меню. Для того, 
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щоб змінити інтервали та кольори в легенді, натисніть правою 

кнопкою миші на легенді, з'явиться діалогове вікно Legend 

Editor. 

 
а)                                                                б) 

Рис. 3.7. Діалогові вікна змін параметрів легенди (а) та вибору 

кольорової схеми (б) 

 

Активізуйте вікно Редактор властивостей (двічі натиснути на 

будь-якому вузлі або ділянці), і розраховані результати 

відображаються в кінці списку характеристик на жовтому фоні 

(рис. 3.8). 

8.2. Створіть список результатів у вигляді таблиці, 

вибравши Report → Table… (рис. 3.9) або натиснувши мишею 

кнопку Table на стандартній панелі інструментів. У вкладці 

Type вибрано відображення вузлів (Network Nodes), а у вкладці 

Columns – вибрано параметри вузлів, які будуть відображені в 

таблиці. На рис. 3.10 показана така таблиця. Потоки, для яких 

вказані від’ємні величини течуть у зворотному напрямку, а не в 

тому, в якому була спочатку нарисована труба. 

8.3. Самостійно створіть табличний список результатів 

розрахунку для ділянок, вибравши їх властивості: довжина, 

діаметр, витрата, швидкість, питомі втрати напору. 

9. Проаналізувати результати розрахунків при відключенні 

водонапірної башти, оформивши звіт в табличній та графічній 

формах. 
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Рис. 3.8. Перегляд результатів розрахунку 

 

 
Рис. 3.9. Діалогове вікно Table Selection 
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Рис. 3.10. Приклад таблиці результатів для труб 

 

 

 

ЛАБОРАТОРНА РОБОТА №4. Динамічне моделювання 

водопровідної мережі. 

 

Мета роботи: отримати навички з моделювання 

водопровідної мережі в реальному часі. 

 

Загальні відомості. 

Тимчасова модель – це набір коефіцієнтів (множників), що 

застосовуються до будь-якої величини та дозволяють їй 

варіюватися за часом. Споживання в вузлі, напір в джерелі, 

графік роботи насоса, якість води, що надходить з джерела, – всі 

ці параметри можуть мати пов'язані з ними тимчасові моделі. 

Часовий інтервал, який використовується у всіх моделях, є 

фіксованою величиною, встановленою в тимчасових 

параметрах. Впродовж даного інтервалу якась величина 

залишається на постійному рівні, рівному номінальному 

значенню. Хоча всі тимчасові моделі повинні використовувати 

один і той же інтервал часу, в кожній з них може бути різна 

кількість періодів. Якщо години модельного часу перевищують 

кількість періодів в моделі, модель повертається до першого 

періоду. 
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Приклад роботи тимчасової моделі розглядає вузол із 

середнім споживанням 10 л/с. Припустимо, що інтервал моделі 

складає 4 год, і для споживання в цьому вузлі була визначена 

модель з такими коефіцієнтами: 

Період 1 2 3 4 5 6 

Коефіцієнт 0,5 0,8 1,0 1,2 0,9 0,7 

 

Тоді під час моделювання фактичне споживання в цьому 

вузлі буде наступним: 

Години 0-4 4-8 8-12 12-16 16-20 20-24 24-28 

Споживання, л/с 5 8 10 12 9 7 5 

 

Оператори управління визначають роботу мережі в 

залежності від часу. Вони визначають стан обраних елементів в 

залежності від часу, рівнів води в водонапірних баштах і напору 

в обраних точках мережі. Можуть використовуватися дві 

категорії операторів управління: 

• прості оператори управління; 

• оператори управління, засновані на правилах. 

Прості оператори управління змінюють стан або установки 

елементів, ґрунтуючись на: 

• рівні води в резервуарі; 

• напорі в з'єднанні; 

• часі моделювання; 

• часі доби. 

Такі оператори використовуються в одному з наступних 

форматів: 

LINK x status IF NODE y ABOVE/BELOW z 

LINK x status AT TIME t 

LINK x status AT CLOCKTIME c AM/PM 

де x – ідентифікаційний номер (ID) ланки; status – OPEN 

(відкрито) або CLOSED (закрито) установки стану ланки; y – ID 

(ідентифікаційний номер) вузла; z – задається параметр в вузлі; t 

– час від початку моделювання в десятковому обчисленні або в 

годинах і хвилинах; c – добовий час (24-год). 
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Ось деякі приклади простих операторів управління: 

Оператор управління Значення 

LINK 12 CLOSED IF 

NODE 23 ABOVE 20 

Закрити ланка 12, якщо рівень у 

башті 23 перевищує 20 м 

LINK 12 OPEN IF 

NODE 130 BELOW 30 

Відкрити ланка 12, якщо напір у вузлі 

130 падає нижче 30 м 

LINK 12 1.5 AT TIME 

16 

Встановити швидкість насоса 12 на 

1,5 о 16 год часу моделювання 

LINK 12 CLOSED AT 

CLOCKTIME 10 AM 
Ланку 12 закрито о 10 ранку та 

відкрито о 8 вечора на весь період 

моделювання 
LINK 12 OPEN AT 

CLOCKTIME 8 PM 

 

Кількість операторів управління, які можна використовувати, 

необмежена. 

Регулювання рівня виражається в підйомі води щодо дна 

резервуара, а не в висоті подачі води. 

Оператори управління, засновані на правилах, дозволяють 

визначати стан і установки ланки на комбінації умов, які можуть 

існувати в мережі після того, як розраховано початковий 

гідравлічний стан системи. Ось кілька прикладів операторів 

управління, заснованих на правилах. 

Приклад 1: при використанні цього набору правил припиняє 

роботу насос і відкривається обвідна труба, якщо рівень води у 

водонапірній башті перевищує певну величину та навпаки, якщо 

рівень води у водонапірній башті нижче певної величини. 

RULE 1 

IF TANK 1 LEVEL ABOVE 19.1 

THEN PUMP 335 STATUS IS CLOSED 

AND PIPE 330 STATUS IS OPEN 

 

RULE 2 

IF TANK 1 LEVEL BELOW 17.1 

THEN PUMP 335 STATUS IS OPEN 

AND PIPE 330 STATUS IS CLOSED 
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Приклад 2: дані правила змінюють рівень води у 

водонапірній башті, при якому насос включається в залежності 

від часу доби. 

RULE 3 

IF SYSTEM CLOCKTIME > = 8 AM 

AND SYSTEM CLOCKTIME < 6 PM 

AND TANK 1 LEVEL BELOW 12 

THEN PUMP 335 STATUS IS OPEN 

 

RULE 4 

IF SYSTEM CLOCKTIME > = 6 PM 

OR SYSTEM CLOCKTIME < 8 AM 

AND TANK 1 LEVEL BELOW 14 

THEN PUMP 335 STATUS IS OPEN 

 

Хід роботи 

Для того, щоб зробити мережу реалістичнішою, створимо 

тимчасову модель, яка буде описувати, як споживання у вузлах 

варіюється впродовж доби. Для цього прикладу будемо 

використовувати 6-годинний крок часової моделі. Споживання 

води, таким чином, буде змінюватися чотири рази на добу. 

1. Відкрити модель мережі, яка розглядалася на попередній 

лабораторній роботі. 

2. Встановимо крок часової моделі, активізувавши вікно 

Times Options (часові параметри): Browser → Data → Options 

→ Times → Edit (кнопка) Введемо значення 6 (Pattern Time 

Step) для кроку часової моделі (рис. 4.1). Також можемо 

встановити тривалість аналізу. Використаємо 3-денний період, 

ввівши 72 год в рядок Total Duration (загальна тривалість). 

3. Для того, щоб створити тимчасову модель, виберіть 

Browser → Data → Patterns (часової моделі) та натисніть на 

кнопку Add. Буде створена нова часова модель 1 і з'явиться 

діалогове вікно Pattern Editor, яке наведене на рис. 4.2. Введіть 

значення коефіцієнта Multiplier: 0.8, 1.1, 1.0, 0.9 для періодів 

часу від 1 до 4, щоб часова модель мала тривалість 24 год. 

Коефіцієнти використовуються для зміни споживання від 

базового рівня в кожен період часу. Так як ми встановили період 
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аналізу 72 год, то модель буде автоматично повертатися до 

початку аналізу кожні 24 год. 

 
Рис. 4.1. Вікно часових параметрів 

 

 
Рис. 4.2. Діалогове вікно редактор часової моделі 
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4. Тепер треба задати часову модель 1 для характеристики 

моделі споживання для всіх вузлів мережі. Можемо 

використовувати одну з опцій гідравліки програми EPANET, 

щоб уникнути редагування кожного з'єднання. Якщо 

активізувати Hydraulics Options: Browser → Data → Options 

→ Hydraulics → Edit, то у вікні є пункт Default Pattern (часова 

модель за замовчуванням). Установка значення 1 зробить так, 

що модель споживання в кожному вузлі буде відповідати 

часовій моделі 1 до тих пір, поки інша модель не буде задана 

для цього вузла. 

 
Рис. 4.3. Діалогове вікно налаштування опцій гідравліки 

 

5. Для того, щоб насос виключався при максимальному рівні 

води в башті та включався – при мінімальному потрібно зайти 

Browser → Data → Controls → Rule-Based → Edit та у вікні 

Rule-Based Control Edited написати два правила: 

Rule 1 

IF TANK 7 LEVEL ABOVE 5  

THEN PUMP 8 STATUS IS CLOSED 
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Rule 2 

IF TANK 7 LEVEL BELOW 1  

THEN PUMP 8 STATUS IS OPEN 

 
Рис. 4.4. Діалогове вікно налаштування включення та виключення 

насосу 

 

6. Запускаємо аналіз: Project → Run Analysis. При 

проведенні продовженого в часі аналізу є декілька способів 

перегляду результатів: 

• Лінійка прокрутки у вікні Browser → Map 

використовується для відображення карти в різні моменти часу. 

Спробуйте зробити це, вибравши Pressure (тиск, вільний напір) 

в якості параметра Nodes і Flow (витрата) як параметр Links. 

• Кнопки, створені в стандартному стилі управління відео, у 

вікні Browser (рис. 1.8) можуть показувати карту, змінюючи її 

за часом (створюючи анімацію). Натисніть кнопку Forward для 

того, щоб почати анімацію і кнопку Stop для того, щоб її 

зупинити. 

• Додайте стрілки, що вказують напрямки потоку на карті: 

View → Options…, виберіть вкладку Flow Arrows з діалогового 

вікна Map Options і призначте стиль стрілок (рис. 4.5). Потім 

знову запустіть анімацію, зверніть увагу, як змінюються 

напрями потоку в трубах, приєднаних до водонапірної башти, 

по мірі того як вода наповнює її (рис. 4.6) і йде з неї (рис. 4.7). 
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Рис. 4.5. Діалогове вікно налаштування параметрів стрілок 

 

 
Рис. 4.6. Результати гідравлічного моделювання для часу 12год 

(наповнення башти) 
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Рис. 4.7. Результати гідравлічного моделювання для часу 22год 

(живлення з башти) 

 

 

• Створіть схему за допомогою часових рядів для будь-якого 

вузла або ділянки. Наприклад, подивіться як змінюється рівень 

води у водонапірній башті за часом: 

1. Натисніть по водонапірній башті. 

2. Виберіть Reports → Graph… або натисніть на кнопку 

Graph на стандартній панелі інструментів. З'явиться діалогове 

вікно Graph Selection. 

3. У діалоговому вікні виберіть тип діаграми Time Series 

(часова). 

4. Виберіть Pressure в якості параметра схеми. 

5. В полі Nodes of Graph додати ще декілька вузлів, які 

будуть відображатися на графіку, наприклад, вузли 2, 5. Для 

цього почергово вибираються вузли та натискається кнопка Add 

(рис. 4.8). 

6. Натисніть кнопку ОК, щоб відобразити графік на екрані 

(рис. 4.9). 

Зверніть увагу на періодичність підйому води в резервуарі в 

залежності від часу (рис. 4.9) та на швидкості руху води на 

ділянці 1 при живленні мережі від насоса та від водонапірної 

башти. 
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Рис. 4.8. Діалогове вікно налаштування параметрів графічного 

відображення результатів розрахунків (вузли) 

 

 
Рис. 4.9. Приклад схеми за допомогою часових рядів для вузлів 
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Рис. 4.10. Діалогове вікно налаштування параметрів графічного 

відображення результатів розрахунків (ділянки) 

 

 
Рис. 4.11. Приклад схеми за допомогою часових рядів для ділянок 
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ЛАБОРАТОРНА РОБОТА №5. Моделювання змін якості 

води у водопровідній мережі 

 

Мета роботи: навчитися моделювати зміну якості води у 

водопровідній мережі та представляти результати моделювання 

в табличній та графічній формах. 

 

Загальні відомості. 

Модель якості води, побудована за допомогою програми 

EPANET, використовує часову функцію Лагранжа для того, щоб 

відстежити, що відбувається з окремими складовими частинами 

води по мірі того, як вони рухаються в трубі та змішуються у 

вузлах в проміжках між фіксованими часовими кроками. Ці 

часові кроки якості води зазвичай набагато коротші, ніж 

гідравлічні часові кроки (не години, а хвилини) для того, щоб 

узгодити короткі періоди переміщення маси води, яке може 

відбуватися в трубах. 

За допомогою цього методу відстежується концентрація та 

розмір ряду сегментів води, які не перекриваються та 

наповнюють кожну ланку мережі. З плином часу, розмір 

сегмента, що знаходиться в найвищій точці перед ланкою 

збільшується по мірі надходження води в ланку мережі, тоді як 

в сегменті, розташованому в нижчій точці за ланкою, 

відбуваються втрати тиску, коли вода витікає з даної ланки 

мережі. Розмір сегментів, розташованих між цими точками 

залишається незмінним. 

Для кожного тимчасового кроку якості води – склад кожного 

сегмента піддається певному впливу – ведеться інтегральний 

облік всієї маси води та об’єму потоку, що надходить на кожен 

вузол, а положення сегментів оновлюється. Потім 

підраховується нова концентрація у вузлі, яка включає в себе 

надходження з будь-яких зовнішніх джерел. Концентрація в 

резервуарі оновлюється в залежності від застосовуваного типу 

змішування. І, нарешті, в кінці кожної ланки створюється новий 

сегмент, який отримує підтік води з вузла, якщо якість нового 

вузла відрізняється від якості останнього сегмента ланки. 
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Спочатку кожна труба в мережі складається з одного 

сегмента, якість якого, дорівнює початковій якості вузла, що 

знаходиться перед ланкою. Як тільки потік в трубі потече у 

зворотний бік, частинки води змінюють свій порядок в 

зворотному напрямку. 

Програма EPANET може використовувати чотири різних 

типи моделей для опису змішування води в водонапірних 

баштах (рис. 5.1): повне змішування; двокамерне змішування; 

потік витіснення типу «першим надійшов – першим 

виводиться» (FIFO); потік витіснення типу «останнім надійшов 

– першим виводиться» (LIFO). У мережі можуть 

використовуватися різні моделі змішування. 

 
а) Модель повного змішування 

(Complete Mixing) 

Застійна 

зона

Зона 

входу-

виходу

 
б) Двокамерна модель (Two-

Compartment Mixing) 

…..

 
в) Модель потоку витіснення типу 

FIFO (Plug Flow – FIFO) 

…
..

 
г) Модель потоку витіснення типу 

LIFO (Plug Flow – LIFO) 

Рис. 5.1. Моделі змішування 

 

Модель повного змішування (рис. 5.1 а) передбачає, що вся 

вода, яка надходить у водонапірну башту, миттєво та повністю 

змішується з водою, що вже в ній знаходиться. 
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Двокамерна модель (рис. 5.1 б) ділить простір у водонапірній 

башті на дві камери, в обох камерах передбачається повне 

змішування. Передбачається, що впускні / випускні труби 

розташовані в першій камері. Нова вода, яка надходить у 

водонапірну башту, змішується з водою в першій камері. Коли 

ця камера заповнюється, надлишок води надходить у другу 

камеру, де змішується з водою, що вже перебуває там. Коли 

вода виходить з водонапірної башти, це відбувається через 

першу камеру, коли вона спорожнюється, то отримує таку саму 

кількість води з другої камери, щоб компенсувати різницю. 

Перша камера може блокувати впуск і випуск води, а в другій 

камері можуть бути застійні зони. Користувач повинен 

призначити один параметр, який є частиною загальної місткості 

башти, відведений на першу камеру. 

Модель потоку витіснення типу FIFO (рис. 5.1 в) 

передбачає, що змішування води не відбувається. Кількість 

води, яка входить в резервуар дорівнює такій же кількості води, 

що виходить з нього. Фізично ця модель найбільш підходить для 

РЧВ. Для опису цієї моделі змішування не потрібно додаткових 

параметрів. 

Модель потоку витіснення типу LIFO (рис. 5.1 г) також 

передбачає, що не відбувається змішування частин води у башті. 

Однак, частини води розташовуються одна над іншою, коли 

вода надходить і виходить з башти зі дна. Цей тип моделі може 

застосовуватися водонапірних башт, коли впускна / випускна 

труба знаходиться в її дні. Тут не потрібно додаткових 

параметрів. 

Програма EAPNET може відслідковувати зміну концентрації 

речовин по мірі їх просування по водопровідній мережі. Для 

цього необхідно знати пропорцію, при якій починається реакція, 

і як ця пропорція може залежати від концентрації речовин. 

Реакції можуть відбуватися всередині самого потоку, а також з 

матеріалом труб. Це показано на рис. 5.2. У цьому прикладі 

вільний хлор взаємодіє з органічною речовиною в загальному 

потоці, а потім переміщується та взаємодіє зі стінкою труби, де 

окислює залізо, через корозію труби. Реакції також можуть 
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відбуватися всередині резервуарів. За допомогою програми 

EPANET можна розглядати ці дві зони реакцій окремо. 

Потік

Пограничний шар

HOCl NOM DBP
Kb

Fe2+ Fe3+Kw

 
Рис. 5.2. Зони реакцій всередині труби 

 

Програма EPANET моделює реакції, що відбуваються в 

масовому потоці, використовуючи кінетику n-го порядку, де 

миттєвий коефіцієнт реакції (R) залежить від концентрації 

R=KbC
n,                                       (5.1) 

де Kb – коефіцієнт реакції в масовому потоці; С – концентрація 

реагенту (кг/м3), n – порядок реакції. Kb додатна для збільшення 

концентрації та від’ємна – для її зменшення. 

 

Програма EPANET може також враховувати реакції, де існує 

гранична концентрація 

R=Kb(CL-C) C(n-1) для n>0, Kb>0;                   (5.2) 

R=Kb(C-CL) C
(n-1) для n>0, Kb<0,                   (5.3) 

де CL – гранична концентрація. 

 

Таким чином, існує три параметри (Kb, CL, n), що 

використовуються для характеристики коефіцієнтів реакцій в 

масовому потоці. Деякі приклади кінетичних моделей наведено 

в табл. 5.1. 

Можна оцінити величину Kb для реакцій першого порядку, 

якщо помістити проби води в скляні пляшки та провести аналіз 

вмісту пляшок в різний час. Якщо це реакція першого порядку, 

тоді графік ln(Ct/С)=f(t) – пряма лінія, де Ct – концентрація при 

часі t, С – концентрація в точці початку відліку часу. 

Коефіцієнти реакцій в масовому потоці зазвичай 

збільшуються при збільшенні температури. Проведення 

багаторазового аналізу при різних температурах забезпечить 
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точнішу оцінку коефіцієнта, що змінюється в залежності від 

температури. 

Таблиця 5.1 

Приклади кінетичних моделей 

Модель Параметри Приклади 

Зменшення концентрації 

першого порядку 
CL=0, Kb<0, n=1 Хлор 

Збільшення 

концентрації першого 

порядку 

CL>0, Kb>0, n=1 Тригалометан 

Кінетика нульового 

порядку 
CL=0, Kb<>0, n=0 

Час перебування 

води в мережі 

Без реакції CL=0, Kb=0 
Відстеження 

фториду 

 

Коефіцієнт реакцій якості води біля стінок труби або на 

стінках труби може розглядатися як залежність від концентрації 

в масовому потоці 

R=(A/V)KwCn,                                    (5.4) 

де Kw – коефіцієнт реакції з матеріалом стінок труби; A/V – 

площа поверхні на одиницю об'єму всередині труби (4/dтр). 

 

Останній вираз конвертує реакції в масовому потоці на 

одиницю площі стінки в одиниці об'єму. EPANET обмежує 

вибір порядку реакції з матеріалом стінки труби – 0 або 1. Що 

стосується параметрів Kb, Kw, то вони повинні бути призначені 

користувачем. Параметри величини Kw першого порядку можуть 

перебувати в діапазоні від 0 до 5 футів/добу (1 фут = 12 дюймів 

= 30,48 см). 

Коефіцієнт Kw повинен бути заданий таким чином, щоб 

передбачити будь-які обмеження масового переміщення 

рухомих реагентів і речовин в проміжку між потоком і стінкою 

труби. EPANET виконує це автоматично, засновуючи підгонку 

величини Kw на коефіцієнті молекулярної дифузії модельованих 

речовин і на числі Рейнольдса потоку (при установці 

молекулярної дифузії 0 ефекти масового перенесення будуть 

ігноруватися). 
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Коефіцієнти реакцій зі стінами труб можуть залежати від 

температури, а також можуть перебувати в співвідношенні з 

віком труби та матеріалом. Добре відомо, що по мірі того, як 

металеві труби старіють їх шорсткість збільшується через іржу й 

осідання продуктів корозії на стінках. Це збільшення шорсткості 

враховує формула Хазен-Вільямса – менше значення 

коефіцієнта С, або формула Дарсі Вайсбаха – більше значення 

коефіцієнта шорсткості, що в результаті збільшує втрати напору 

в трубі. 

Можна з очевидністю припустити, що ті ж процеси, які 

збільшують шорсткість труб з віком, також збільшують 

реакційну здатність стінок труб з деякими хімічними 

елементами, особливо з хлором й іншими дезінфікуючими 

речовинами. Програма EAPNET може визначити величину Kw 

як функцію коефіцієнта, що використовується для опису 

шорсткості. Для розрахунку втрат напору в трубі 

застосовуються різні функції, що наведені в табл. 5.2. 

Таблиця 5.2. 

Формула реакції зі стінками труб в залежності від прийнятої 

формули втрат напору 

Формула втрат напору Формула реакції зі стінками труб 

Хазен–Вільямс Kw=F/C 

Дарсі–Вейсбах Kw=-F/log(e/d) 

Чезі–Меннінг Kw=Fn 

 

Тут С – коефіцієнт С Хазен-Вільямса, е – шорсткість по Дарсі-

Вейсбаху, d – діаметр труби, n – коефіцієнт шорсткості 

Меннінга, F – коефіцієнт реакції зі стінкою труби – шорсткість 

труби. Коефіцієнт F повинен бути розрахований за допомогою 

замірів на місці та матиме різні значення в залежності від того, 

яка формула втрат напору використовується. Перевага такого 

підходу в тому, що потрібно тільки один параметр F, щоб 

коефіцієнти реакцій зі стінками труб змінювалися за всією 

мережею у фізичному сенсі. 

В доповнення до розподілу хімічних речовин EPANET може 

також моделювати зміни віку води в мережі. Вік води – це 

тривалість перебування води в розподільчій системі. Вода, що 
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надходить в мережу з джерела або з вузла, має вік рівний нулю. 

Вік води є простим, не специфічним способом вимірювання 

якості питної води у мережі. EPANET розглядає вік води як 

реактивну складову, збільшення якої відбувається відповідно до 

правил кінетики нульового порядку, з коефіцієнтом 1 

(наприклад, кожну секунду вік води збільшується на секунду). 

EPANET також може виконати моніторинг джерела. 

Моніторинг джерела відбувається в залежності від часу та 

відстежує, який відсоток води, що досягає будь-якого вузла 

мережі, взято з певного джерела. Вузол-джерело – це будь-який 

вузол мережі, включаючи джерела та резервуари. EPANET 

розглядає такий вузол як постійне джерело нереактивної 

складової, яка надходить в мережу маючи концентрацію 100. 

Моніторинг джерела – це корисний інструмент для аналізу 

розподільчої системи, в яку вода надходить з двох або більше 

джерел. Можна побачити як змішуються води з різних джерел за 

часом. 

 

Хід роботи 

1. Відкрити модель мережі, яка розглядалася на попередній 

лабораторній роботі. 

2. Виконаємо аналіз якості води. Найпростіший спосіб 

включити аналіз якості води – відстежити зміну часу 

перебування води в мережі за часом. Потрібно зайти: Browser 

→ Data → Options → Quality → Edit. У вікні Quality Options в 

полі Parameter вибрати Age (вік, тривалість перебування води в 

мережі) – рис. 5.3. Запустіть аналіз і виберіть Age як параметр 

перегляду карти. Створіть схему за допомогою часових рядів 

для визначення віку перебування води в башті (рис. 5.4, 

рис. 5.5).  

3. Для моделювання руху та зміни концентрації хлору в 

мережі потрібно: 

3.1. Вибрати Browser → Data → Options → Quality → Edit. 

В полі Parameter (параметр) діалогового вікна Quality Options 

надрукуйте слово Chlorine (хлор) – рис. 5.6. 

3.2. Перейдіть на Browser → Data → Options → Reactions 

→ Edit (рис. 5.7). Введіть значення -1.0 для Global Bulk Coeff. 
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(глобальний коефіцієнт реакції потоку). Він відображає 

коефіцієнт, при якому концентрація хлору буде зменшуватися, в 

результаті дії потоку з часом. Цей коефіцієнт 

застосовуватиметься до всіх труб в мережі. Можна змінювати 

цей коефіцієнт для кожної окремої труби. 

 

 
Рис. 5.3. Діалогове вікно параметрів якості 

 

 
Рис. 5.4. Діалогове вікно налаштування параметрів графічного 

відображення результатів розрахунків (ділянки) 
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Рис. 5.5. Вік води в башті 

 

 
Рис. 5.6. Діалогове вікно параметрів якості 

 

 
Рис. 5.7. Діалогове вікно параметрів реакції 

 

3.3. Натисніть по вузлу резервуара та встановіть Initial 

Quality (початкова якість) 1. Це буде концентрація хлору, що 
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надходить в мережу. Встановіть початкове значення якості в 

водонапірній башті 0. 

  
Рис. 5.8. Налаштування параметрів початкових концентрацій в 

резервуарі та башті 

3.4 Запустіть приклад на виконання (кнопка Run ). 

3.5. Перейдіть на Browser → Map → Links → Chlorine. 

Тепер у вікні Network Map можна бачити як змінюється 

концентрація хлору в різних місцях мережі та за часом 

впродовж періоду моделювання (рис. 5.10-5.12). 

6. Створіть звіт для аналізу зміни концентрації активного 

хлору, вибравши Report → Reaction. Звіт буде виглядати так, як 

показано на рис. 5.13. Тут показано, як в середньому 

зменшується концентрація хлору в трубах в порівнянні з 

резервуаром. Термін «Bulk» (потік) відноситься до реакцій, що 

відбуваються в потоці, тоді як термін «Wall» (стінки) 

відноситься до реакцій з матеріалами, з яких зроблені стінки 
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труби. В нашому випадку реакція зі стінками була прийнято 0, 

так як не встановлювався цей коефіцієнт. 

 

 
Рис. 5.9. Вікно перегляду 

 

 
Рис. 5.10. Результати моделювання зміни концентрації активного 

хлору для початкового моменту моделювання 
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Рис. 5.11. Результати моделювання зміни концентрації активного 

хлору для моменту моделювання – день 1, 15-00 год 

 

 
Рис. 5.12. Результати моделювання зміни концентрації активного 

хлору для моменту моделювання – день 3, 13-00 год 

 

7. Проаналізуйте вплив різних моделей змішування у 

водонапірній башті на динаміку концентрації активного хлору у 

водопровідній мережі. 

8. Використовуючи розроблену імітаційну модель мережі, 

визначте значення коефіцієнтів реакції в потоці та стінках для 
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хлору так, щоб середні швидкості реакцій співвідносилися: 

реакція в потоці : на стінці труби : в башті, % – 15:80:5. 

 
Рис. 5.13 Приклад звіту для аналізу зміни концентрації активного 

хлору 
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